Como Actualizar PLEX AUTOMÁTICAMENTE a la última versión

Vamos a ejecutar unos comandos y programar una tarea para que nuestro servidor Plex se actualice de forma automática. Este artículo es una traducción y adaptación propia del original que puedes ver aquí.

Suscríbete para recibir las últimas novedades

 

Loading

Habilite la actualización del repositorio para las distribuciones de servidor Linux compatibles

Unreal PT Demo Gameplay Español Descarga

Hola! A continuación os dejo los enlaces de descarga de las diferentes versiones que vaya localizando:

Torrent 

Descarga directa Telegram

 

Configurar VPN en Mikrotik básica con L2TP – IpSec

Buenos días, en este manual vamos a ver como configurar una VPN sencilla en MIkrotik. Está basado en el manual oficial de Mikrotik pero traduciéndolo al Español e intentado aclarar los pasos, así como corregir algún comando de versiones antiguas.

Este ejemplo demuestra cómo configurar fácilmente el servidor L2TP / IpSec en el enrutador Mikrotik para conexiones de clientes (funciona con Windows, Android y iPhones).

Todas estas opciones también se pueden hacer por la interfaz gráfica, por ejemplo, cuando pone /interface puedes ir a interface y luego al resto de opciones.

El primer paso es habilitar el servidor L2TP:

/interface l2tp-server server
set enabled=yes use-ipsec=required ipsec-secret=mySecret default-profile=default

required está configurado para asegurarse de que solo se aceptarán conexiones L2TP encapsuladas con IPSec.

Ahora, lo que hace es habilitar el servidor L2TP y crear ipsec peer dinámico con un secreto especificado

/ip ipsec peer print

Nota: Se debe tener cuidado si existe una configuración de pares ipsec estática.

El siguiente paso es crear un grupo de VPN y agregar algunos usuarios.

/ip pool add name=vpn-pool range=192.168.99.2-192.168.99.100 
/ppp profile
set default local-address=192.168.99.1 remote-address=vpn-pool 
/ppp secret
add name=user1 password=123
add name=user2 password=234

Si hay políticas de firewall estrictas, no olvide agregar reglas que acepten l2tp e ipsec.

/ip firewall filter
add chain=input protocol=udp port=1701,500,4500
add chain=input protocol=ipsec-esp

Ahora el enrutador está listo para aceptar conexiones de cliente L2TP / IpSec.

Aquí podéis ver una captura de los comandos:

Aquí nos tenemos que ir al Firewall y subir estas dos reglas que hemos creado y están en la parte de abajo, por encima del primer Drop.

En el Log, podemos comprobar que sucede, aquí en rojo se ve error, pero luego abajo ya conecta.

💻 Cómo actualizar PLEX manualmente – LINUX – OMV 5 DOCKER

Buenos días, vamos a actualizar Plex por línea de comandos manualmente dado que por alguna extraña razón no lo han hecho para que se actualice solo.

Lo primero que tenemos que hacer es ir a su Web pinchando AQUÍ y copiar la dirección de la versión que necesitemos, para Raspberry Pi, que será en Linux y Ubuntu (16.04+) / Debian (8+) – ARMv7

Una vez hecho esto, nos meteremos por terminal a nuestro dispositivo o por SSH con Putty por ejemplo.

Si lo tienes en un Docker como es mi caso y en el vídeo, tienes que meter el siguiente comando para entrar en el Docker, cambiando el nombre plex por el que le pusieras al tuyo (es posible que tengas que usar sudo):

docker exec -it plex /bin/bash

Ya dentro, descargamos el archivo con el comando wget y pegando la ruta que copiamos de su página web, por ejemplo:

wget https://downloads.plex.tv/plex-media-server-new/1.20.4.3517-ab5e1197c/debian/plexmediaserver_1.20.4.3517-ab5e1197c_armhf.deb

Y ahora instalamos con el comando dpgk-i más el nombre del archivo, podemos escribir plex y dar a tabulador para que lo complete, o mirar con ls como se llama. Por ejemplo 

dpkg -i plexmediaserver_1.20.4.3517-ab5e1197c_armhf.deb

Se recomienda reiniciar el Docker Plex una vez que se ha instalado.

Te recomiendo hacer Backup de tus Docker por si acaso antes de hacer cambios.

📁 Como instalar RCLONE en WINDOWS 10 ☁️

Web de descarga: https://rclone.org/downloads/

Lista de comandos: https://rclone.org/commands/

Para instalar:

cd "Ruta carpeta donde lo hemos descargado"
rclone config

Ir configurado según el vídeo.

Ejemplos

Para copiar:

rclone copy ArchivoOrigen NombreDestinoNube(El que pusimos en la instalación) 

Crear carpeta

rclone copy ArchivoOrigen NombreDestinoNube(El que pusimos en la instalación) .

 

 

⚽ Instalar Addons SPORTHD KODI deportes multidioma

En este Addons podrás encontrar deportes en vivo y en múltiples idiomas, entre ellos el español.

Necesitas activar en las opciones de Kodi que se puedan instalar Addons no oficiales.

Sí ya lo tienes, vamos con el resto:

Ajustes (rueda de engranaje)

Administrador de archivos

Añadir fuente y ponemos: https://bugatsinho.github.io/repo -> nombre bugatshino

Vamos en el menú principal a Addons y después Complementos, icono de la caja abierta.

Instalar desde archivo zip

Buscamos bugatshino e instalamos:repository.bugatshino-x.x.zip

Después Instalar desde repositorio: Bugatshino repository

Complementos para video: SportHD

Instalar

Damos OK para instalar los addon necesarios y esperamos a que esté instalado.

Ya podemos ir al addon SportHD y usarlo porque ya estará listo.

Si esto no te ha funcionad, haz primero lo siguiente:

Añade la fuente https://bugatsinho.github.io/test, agrega el addon plugin.video.sporthdme-x.x.x.zip y vuelve a probar.

Deja tú comentario.

Fuente.

 

RCLONE montar carpetas GOOGLE DRIVE para PLEX y Raspberry Pi

Cosas que vamos a usar:

Instalar Raspberry OS/Raspbian

Downloads

Instalar RClone

Desde terminal o por SSH:

curl https://rclone.org/install.sh | sudo bash

Reiniciaremos la Raspberry Pi y ahora ejecutamos:

sudo dpkg -i rclone*.deb

rm rclone*.deb

Configurar RClone

Sigue el primer vídeo para Linux y el segundo para Windows.

Montando nuestra nube de Google Drive como servicio

Vamos a crear un archivo con la configuración del servicio y crear la carpeta donde irá. 

mkdir -p ~/.config/systemd/user
nano ~/.config/systemd/user/rclone@.service

Una vez tenemos abierto con el edito nano, copiamos esto.

[Unit]
Description=rclone: Remote FUSE filesystem for cloud storage config %i
Documentation=man:rclone(1)

[Service]
Type=notify
ExecStartPre=/bin/mkdir -p %h/mnt/%i
ExecStart= \
  /usr/bin/rclone mount \
    --config="%h/.config/rclone/rclone.conf" \
    --allow-other \
    --drive-acknowledge-abuse=true \
    --fast-list \
    --vfs-cache-mode writes \
    --vfs-cache-max-size 100M  \
    --umask 0777 \
    %i: %h/mnt/%i
ExecStop=/bin/fusermount -u -z %h/mnt/%i
ExecStop=/bin/rmdir %h/mnt/%i
Restart=on-failure
[Install]
WantedBy=default.target

Salimos de nano con Ctrl+X y guardar con Y o S

Ahora habilitamos el servicio para que arranque al encender la Raspberry Pi con:

systemctl --user enable rclone@drive

Cambia en rclone@drive la palabra drive con el nombre que tú le pusiste. Si tienes varias configuraciones puede repetir este comando por cada una cambiando el nombre.

Ahora ya reinicia y después te aparecerá montada si todo ha salido bien.

Comandos Rclone

Este es un índice de todos los comandos en rclone. Ejecute rclone command --help para ver la ayuda de ese comando

 

 

 

 

 

Plantillas Aplicaciones PORTAINER 2 0 con TAISUN

Como tras actualizar a Portainer 2.0 las plantillas anterior no nos funcionan, vamos a ver como podemos ir usando plantillas, por ejemplo con Taisun

Antés de nada te dejo este artículo oficial como alternativa.

Cómo convertir sus plantillas para 1.xa 2.0

How to convert your templates for 1.x to 2.0

Taisun

Para instalar Taisun , simplemente copie el siguiente código en una nueva Stack de Portainer:

---
version: "2"
services:
  taisun:
    image: linuxserver/taisun
    container_name: taisun
    network_mode: bridge
    volumes:
      - /var/run/docker.sock:/var/run/docker.sock
    ports:
      - 3000:3000
    restart: unless-stopped

Bajar a la versión 1.24.x

Siempre puedes volver a la versión anterior con los siguientes comandos.

docker stop portainer
docker rm portainer

Una vez que hayas eliminado Portainer, puedes ejecutar los siguientes comandos para ejecutar la versión 1.24.x:

docker volume create portainer_data
docker run -d -p 9000:9000 -p 8000:8000 --name portainer --restart always -v /var/run/docker.sock:/var/run/docker.sock -v portainer_data:/data portainer/portainer

Tutoriales de OpenMediaVault

Fuente

RASPBERRY PI 4 arrancar desde SSD o USB

¡Hola a todos! En este vídeo vamos a configurar para arrancar nuestra Raspberry Pi 4 desde USB o SSD sin necesidad de MicroSD. Te dejo el vídeo a continuación.

19/01/2021 Actualizo con los comandos para hacerlo de forma más rápida y sencilla:

sudo apt update
apt full-upgrade
nano /etc/default/rpi-eeprom-update
rpi-eeprom-update -d -a
reboot
vcgencmd bootloader_version

Sí ya vienes del vídeo y estás buscando la descarga, pincha AQUÍ

Existe otra alternativa con Berryboot, que permite además tener más de un sistema operativo a la vez y elegir desde cual arrancar. Pero si necesitaremos tener la MicroSD conectada.

La MicroSD tiene un ancho de banda máximo teórico de apenas 50 Mbps en la Raspberry Pi 4 y de 25 Mbps en modelos anteriores. Por el contrario, si usamos un soporte USB se puede alcanzar hasta 140 MB/s de lectura y 208 MB/s de escritura utilizando un SSD conectado por USB a una Raspberry 4.

Vamos ya con los pasos que tenemos que hacer en terminal para ello. Lo primero actualizar al máximo nuestro Raspbian o sistema operativo que usemos.

sudo apt update
sudo apt full-upgrade

Tienes que editar un fichero para que permita instalar esta actualización de Firmware de la que hablamos, dado que es un Firmware en fase Beta. Introduce el siguiente comando:

sudo nano /etc/default/rpi-eeprom-update

En el editor, cambia el valor «critical» por «beta» y pulsa CTRL + X para salir, y S o Y para guardar.

sudo rpi-eeprom-update -d -f /lib/firmware/raspberrypi/bootloader/beta/pieeprom-2020-05-15.bin

Es posible que este proceso falle si ha salido un firmware más moderno, en cuyo caso deberás comprobar la fecha del mismo. Para ello, simplemente ve al directorio /lib/firmware/raspberrypi/bootloader/beta/ y comprueba el nombre del archivo pieeprom.

Después reinicia la Raspberry Pi.

Para comprobar que se ha hecho bien ejecuta el siguiente comando, tiene que salirte una fecha como la del instalador.

vcgencmd bootloader_version

Si todo es correcto, ahora tendrás que copiar el sistema operativo de tú MicroSD al USB con SD Card Copier integrado en Raspbian o con otro sistema, o instalar directamente en tú USB el sistema operativo.

Para terminar, tenemos que copiar del siguiente archivo que bajemos desde AQUÍ los archivos que están dentro del directorio /boot con extensión *.dat y *.elf en la partición «boot» del dispositivo USB, sobreescribiendo los existentes. Esto yo lo haré desde un ordenador con Windows.

Ahora ya puedes quitar la MicroSD de la Raspberry Pi y conectar el dispositivo USB, y ya debería arrancar desde este.

Posibles errores

Hay que tener en cuenta que ahora la Raspberry está alimentando el disco duro por USB y que no tenga suficiente alimentación para otros dispositivos que conectes. Para solucionarlo, puedes usar una base para disco duro con alimentación externa.

Fuente

 

 

Cómo configurar un servidor Raspberry Pi Plex

Necesitará el siguiente equipo para poder completar este tutorial del servidor Raspberry Pi Plex.

Recomendado

 Raspberry Pi 2, 3 o más reciente

 Tarjeta micro SD

 Fuente de alimentación

 Cable Ethernet o Adaptador Wifi si no tiene interno (aunque es mejor quedarse con Ethernet para un servidor de medios)

Opcional

 Carcasa Raspberry Pi

 Teclado USB

 Ratón USB

 Disco duro externo o unidad USB  (para almacenar películas, música y fotos)

 Configuración del servidor Raspberry Pi Plex

En este tutorial, usaré Raspbian/Raspberry OS, así que si no lo tienes instalado, consulta el siguiente vídeo.

Preparando su Pi para Plex

1. Ahora, antes de instalar el software Plex Media Server en la Raspberry Pi, primero debemos asegurarnos de que nuestro sistema operativo esté completamente actualizado ejecutando los siguientes dos comandos.

sudo apt-get update
sudo apt-get upgrade

2. Para instalar los paquetes Plex en Raspberry Pi, necesitaremos agregar el repositorio oficial de paquetes Plex.

Antes de hacer eso, necesitamos instalar el apt-transport-https paquete.

Este paquete permite al apt administrador de paquetes » https» recuperar paquetes a través del protocolo que utiliza el repositorio de Plex.

Instale el paquete ejecutando el siguiente comando.

sudo apt-get install apt-transport-https

3.Ahora agreguemos los repositorios de Plex a la apt lista de claves de los administradores de paquetes.

Esta clave se utiliza para garantizar que los archivos que está descargando sean de ese repositorio y estén firmados por esa clave.

Ejecute el siguiente comando para descargar y agregar la clave al administrador de paquetes.

curl https://downloads.plex.tv/plex-keys/PlexSign.key | sudo apt-key add -

4.Con la clave Plex GPG ahora agregada, finalmente podemos agregar el repositorio plex oficial a la lista de fuentes ejecutando el siguiente comando.

echo deb https://downloads.plex.tv/repo/deb public main | sudo tee /etc/apt/sources.list.d/plexmediaserver.list

5.Como acabamos de agregar un nuevo repositorio a nuestras fuentes, necesitaremos ejecutar el comando «actualizar » nuevamente para actualizar la lista de paquetes.

sudo apt-get update

Si recibe el error » /usr/lib/apt/methods/https could not be found.«, el paquete de transporte https no se ha instalado. Verifique que se haya instalado correctamente.

Instalación de Plex en su Raspberry Pi

1. Ahora que hemos configurado nuestra Raspberry Pi para que pueda leer de los repositorios de paquetes oficiales de Plex, podemos continuar y finalmente instalar el paquete del servidor Plex Media en la Pi.

Para instalar el plexmediaserverpaquete » «, ejecute el siguiente comando.

sudo apt install plexmediaserver

2. El proceso de instalación de Plex configura algunas cosas diferentes para nosotros.

La primera es que crea un usuario y un grupo para que Plex se ejecute. Este usuario y grupo se llama «plex«.

También configurará dos directorios, uno donde almacenar los archivos temporalmente que Plex está transcodificando. Puede encontrar esta carpeta en “ /var/lib/plexmediaserver/tmp_transcoding“.

El segundo directorio es donde Plex almacenará todos los metadatos que recupere para sus medios. Esta carpeta se puede encontrar en » /var/lib/plexmediaserver/Library/Application Support«

3.Como Plex está ejecutando un usuario diferente al usuario “pi” predeterminado de Raspberry Pi , deberá asegurarse de tener los permisos configurados correctamente en su disco.

Para evitar esto, puede cambiar el usuario que usa Plex con el siguiente comando, y después reiniciarlo.

Una vez hecho esto, salga presionando CTRLXy luego spara guardar.

sudo nano /usr/lib/plexmediaserver/lib/plexmediaserver.default

export PLEX_MEDIA_SERVER_USER=pi (Pondrá Plex originalmente y quitaremos la #)

sudo systemctl restart plexmediaserver

Configuración de una dirección IP estática para su servidor Plex

1. Ahora que hemos instalado Plex en nuestra Raspberry Pi, debemos asegurarnos de que estamos usando una dirección IP estática .

Hay dos razones para utilizar una IP estática. Una es que la IP será más fácil de recordar. En segundo lugar, se asegurará de que su servidor Plex siempre se pueda encontrar en la misma dirección.

Para obtener su dirección IP actual, ingrese el siguiente comando.

hostname -I

2.Ahora abre el cmdline.txt archivo.

sudo nano /boot/cmdline.txt

3. En la parte inferior de este archivo, agregue la siguiente línea: (Reemplazando “ YOUR IP” con la IP que obtuvo al usar el nombre de host -I)

ip=YOUR IP

4. Una vez hecho esto, salga presionando CTRLXy luego spara guardar.

5. Ahora simplemente reinicie el Pi ejecutando el siguiente comando.

sudo reboot

6. El Pi ahora debería comenzar siempre con la misma IP. También puede configurar esto en la mayoría de los enrutadores vinculando la dirección mac de su dispositivo de red (WiFi o Ethernet) a una IP.

Ahora el servidor de medios Raspberry Pi Plex debería estar configurado y listo para escanear sus medios y transmitirlos a cualquier cliente que desee conectarse. Revisaré algunos conceptos básicos para configurar todo a continuación.

Para que pueda leer los archivos en el directorio que vamos a usar para los vídeos, tiene que tener los permisos necesarios.

Más INFO y Fuente.